System Latency on GCP Asia region

Incident Report for EdCast by Cornerstone

Resolved

The elevated latency issue affecting GCP Asis has been successfully resolved.

We have verified that latency metrics have returned to expected thresholds and all impacted services are now operating normally.

The RCA for the issue will be shared within 7 to 10 business days.

Thank you for your patience and understanding during this incident.
Posted Mar 03, 2026 - 02:18 PST

Update

The system performance on the GCP ASIA swimlane has remained stable post resolution. We did not record any latency concerns on GCP Asia and we continue to monitor the environments to ensure continued stability before concluding a closure of this incident.
Posted Mar 01, 2026 - 22:09 PST

Update

The system performance on the GCP ASIA swimlane has remained stable post resolution. We did not record any latency concerns on GCP Asia and we continue to monitor the environments to ensure continued stability before concluding a closure of this incident.
Posted Mar 01, 2026 - 14:33 PST

Update

The system performance on the GCP ASIA swimlane has remained stable post resolution. We did not record any latency concerns on GCP Asia and we continue to monitor the environments to ensure continued stability before concluding a closure of this incident.
Posted Mar 01, 2026 - 14:30 PST

Monitoring

The performance issue with the GCP ASIA swimlane has been resolved, and the sites are now loading as expected. We are currently monitoring the environments to ensure continued stability.
Posted Feb 26, 2026 - 20:55 PST

Investigating

We are currently experiencing performance slowness on the GCP Asia Production environment. Our Operations team is actively working to restore the instance to normal performance levels.

We appreciate your time and patience.
Posted Feb 26, 2026 - 20:34 PST
This incident affected: Mumbai (GCP) (Web, API, Data and Analytics, Content Integrations).