Latency Observed in US WEST region PROD in LMS and LXP pages

Incident Report for EdCast by Cornerstone

Postmortem

Issue Summary:
On February 23, 2026, increased latency was observed across all U.S. swimlane environments due to an issue with an internal service that depends on a third-party database service (ArangoDB). The incident affected Galaxy customers using LXP and LMS, including environments running LXP and LMS together, or LXP alone. During the affected period, users experienced slower page load times and delayed system responses.

Root Cause:
The incident was caused by a disruption in the third-party ArangoDB service used by an internal platform component. The dependency caused the internal service to experience latency, which propagated to all US swimlane environments and resulted in broader platform responsiveness degradation.

Corrective Action:
Engineering teams collaborated with the ArangoDB vendor to identify and address the service disruption. Once the vendor restored normal operation of the database service, the dependent internal services recovered and system performance returned to expected levels.

Preventive Measures:
To reduce the likelihood of a similar incident in the future, the following improvement is being implemented:

  • Implement Circuit Breaker: Introducing circuit breaker within internal services to prevent dependency failures from propagating and causing broader platform latency.
Posted Mar 12, 2026 - 13:23 PDT

Resolved

The CSOD Technology Team observed a performance degradation affecting this swimlane. The problem began at 7:54 AM Pacific Time and was resolved at 10:48 AM Pacific Time. During this time, clients with portals on this swimlane may have experienced slow performance or intermittent errors while accessing the application.
Posted Feb 23, 2026 - 14:24 PST

Monitoring

The issue has been identified and resolved, and services have been restored to normal operations. We will continue to monitor the situation closely.
Posted Feb 23, 2026 - 10:09 PST

Identified

We have identified the issue, and our team is currently working on a resolution. Thank you for your patience and understanding.
Posted Feb 23, 2026 - 08:03 PST

Investigating

We are currently investigating reports of increased latency affecting all US swimlane environments (Pilot, Sandbox, and Production). This issue impacts Galaxy customers using LXP and LMS, or LXP alone, and may result in slower page load times.

Our engineering team is actively working on the identification of the cause.

We are actively working to restore normal response times and will continue to provide updates as we progress.

Thank you for your patience and understanding.
Posted Feb 23, 2026 - 07:56 PST
This incident affected: US West (Web, API, Data and Analytics, Content Integrations).