After a period of monitoring with no further recurrence observed, the issue is now considered resolved.
The CSOD Technology Team identified a performance degradation impacting EU Production (Galaxy Customers). The issue began at 4:28 AM Pacific Time and was resolved at 5:19 AM Pacific Time. During this period, clients with portals in this region may have experienced slow performance or intermittent errors while accessing/working on the application.
Posted Feb 24, 2026 - 11:24 PST
Monitoring
The issue has been identified and resolved, and services have been restored to normal operations. We will continue to monitor the situation closely.
Posted Feb 24, 2026 - 06:04 PST
Identified
Our Engineering team has identified the root cause and is actively working to restore normal response times. We will continue to share updates as progress is made.
Posted Feb 24, 2026 - 05:45 PST
Investigating
We are currently investigating reports of increased latency affecting EU region Production Environment. This issue impacts Galaxy customers using LXP and LMS, or LXP alone, and may result in slower page load times and eventually erroring out.
Our Engineering team is investigating on the root cause and is actively working to restore normal response times. We will continue to share updates as progress is made.
Thank you for your patience and understanding.
Posted Feb 24, 2026 - 04:58 PST
This incident affected: Europe (API, Web, Data and Analytics, Content Integrations).