Minor Issue - Elevated Latency Observed in Prod US East 08

Incident Report for EdCast by Cornerstone

Resolved

This issue is now resolved.
Posted Apr 27, 2026 - 17:04 PDT

Monitoring

Cornerstone Engineering was alerted to latency on Prod US East 08. The environment has since recovered and we are currently monitoring to ensure stability. We will mark this issue Resolved after ~1 hour.
Posted Apr 27, 2026 - 15:41 PDT
This incident affected: US East 08 (Web, API, Data and Analytics, Content Integrations).