The elevated latency issue affecting GCP Asia has been successfully resolved.
We have verified that latency metrics have returned to expected thresholds and all impacted services are now operating normally.
The RCA for the issue will be shared within 7 to 10 business days.
Thank you for your patience and understanding during this incident.
Posted Nov 19, 2025 - 01:04 PST
Monitoring
The performance issue with the GCP ASIA swimlane has been resolved, and the sites are now loading as expected. We are currently monitoring the environments to ensure continued stability.
Posted Nov 18, 2025 - 22:28 PST
Investigating
We are currently experiencing slowness on the production site for GCP ASIA. We are actively working to restore normal response times and will continue to provide updates as we progress.
Thank you for your patience and understanding.
Posted Nov 18, 2025 - 21:10 PST
This incident affected: Mumbai (GCP) (Web, API, Data and Analytics, Content Integrations).