Latency and overall site performance have stabilized, and response times have returned to normal. We will continue to monitor the situation. Thank you for your patience.
Posted Jan 23, 2026 - 09:55 PST
Identified
We have identified the issue, and our team is currently working on a resolution. Thank you for your patience and understanding.
Posted Jan 23, 2026 - 09:14 PST
Update
We are continuing to investigate this issue and will continue to provide updates as we progress.
Posted Jan 23, 2026 - 07:06 PST
Investigating
We are once again seeing reports of higher latency impacting EU Production. Users may experience slower load times, delayed responses, or intermittent timeouts when interacting with the overall application.
We are actively working to restore normal response times and will continue to provide updates as we progress.
Thank you for your patience and understanding.
Posted Jan 23, 2026 - 03:58 PST
Monitoring
Latency and overall site performance have improved and returned to normal levels. The impact began at 07:04 AM PT and was restored by 07:40 AM PT. Our team continues to monitor the service closely while also investigating the root cause to ensure full stability. We will share further updates as we make additional progress. Thank you for your patience and understanding.
Posted Jan 21, 2026 - 09:57 PST
This incident affected: Europe (API, Web, Data and Analytics, Content Integrations).