Minor Issue - Elevated Latency Observed in EU Production

Incident Report for EdCast by Cornerstone

Resolved

The elevated latency issue affecting EU has been successfully resolved.

We have verified that latency metrics have returned to expected thresholds and all impacted services are now operating normally.

We will continue to monitor the system to ensure continued stability. The RCA for the issue will be shared within 7 to 10 business days.

Thank you for your patience and understanding during this incident.
Posted Jan 19, 2026 - 02:20 PST

Update

We are continuing to monitor for any further issues.
Posted Jan 18, 2026 - 19:58 PST

Monitoring

An off-cycle fix has been deployed on, Saturday, January 17, 2026. Issue should be resolved fully. We will continue to closely monitor the environment before confirming that this incident has been fully resolved.
Posted Jan 18, 2026 - 20:00 PST

Investigating

While the systems remained stable, some of the Galaxy users may still observe the latency issue intermittently. CSOD engineering teams continue to investigate the root cause and address the issue on priority. We will share the progress on this issue on a regular basis.
Posted Jan 16, 2026 - 06:16 PST

Monitoring

System performance has been stable in the last few hours. We continue to closely monitor before concluding that this incident has been resolved.
Posted Jan 15, 2026 - 00:10 PST

Update

We are continuing to investigate and are working to restore normal response times. We will provide updates as we make progress. Thank you for your understanding and patience.
Posted Jan 14, 2026 - 22:45 PST

Update

We are seeing an improvement in site performance. The team continues to investigate the issue and is actively working to restore normal response times.

We will share updates as we make further progress. Thank you for your understanding and patience.
Posted Jan 14, 2026 - 20:44 PST

Update

We are continuing to investigate and are working to restore normal response times. We will provide updates as we make progress. Thank you for your understanding and patience!
Posted Jan 14, 2026 - 18:35 PST

Update

Our investigation into this issue is ongoing. It remains a top priority for our engineering teams. We will continue to provide updates at least every 2 hours until resolved. We appreciate your patience and understanding.
Posted Jan 14, 2026 - 15:45 PST

Update

We remain actively engaged and continue investigating the issue. We will share regular updates until the issue is resolved. Thank you for your patience and understanding.
Posted Jan 14, 2026 - 13:49 PST

Update

We are actively investigating the issue as a top priority. We will continue to share updates as more information becomes available. Thank you for your continued patience.
Posted Jan 14, 2026 - 11:48 PST

Update

Our engineering teams are continuing to investigate this issue with top priority to restore system stability and response times. We will share updates as our investigation progresses.
Posted Jan 14, 2026 - 09:40 PST

Update

We are continuing to investigate this issue and are actively working to restore normal response times. Updates will be provided as progress is made.

Thank you for your patience and understanding.
Posted Jan 14, 2026 - 06:23 PST

Investigating

We are currently investigating reports of increased latency affecting EU Production.
Users may experience slower load times, delayed responses, or intermittent timeouts.

We are actively working to restore normal response times and will continue to provide updates as we progress.

Thank you for your patience and understanding.
Posted Jan 14, 2026 - 02:57 PST
This incident affected: Europe (API, Web, Data and Analytics, Content Integrations).