System Latency on GCP Asia region

Incident Report for EdCast by Cornerstone

Update

We have been monitoring since yesterday and have observed that the sites are loading as expected. We will continue to monitor to ensure sustained performance.
Posted Jan 20, 2026 - 21:38 PST

Monitoring

The performance issue with the GCP ASIA swimlane has been resolved, and the sites are now loading as expected. We are currently monitoring the environments to ensure continued stability.
Posted Jan 19, 2026 - 21:25 PST

Investigating

We are currently experiencing performance slowness on the GCP Asia Production environment. Our Operations team is actively working to restore the instance to normal performance levels.

We appreciate your time and patience.
Posted Jan 19, 2026 - 20:46 PST
This incident affects: Mumbai (GCP) (Web, API, Data and Analytics, Content Integrations).