Latency and usability issue with Talent Marketplace Feature for AP and EU Regions

Incident Report for EdCast by Cornerstone

Resolved

The issues seen across Talent Market Place has been successfully resolved.

The problem began at 5:10am Pacific Time and was resolved at 11:45am Pacific Time. CSOD team have taken necessary steps to restore normal performance levels.

We have verified that latency metrics have returned to expected thresholds and all impacted services are now operating normally.

After a period of monitoring we are considering this issue resolved. The RCA for the issue will be shared within 7 to 10 business days.

Thank you for your patience and understanding during this incident.
Posted Dec 22, 2025 - 13:57 PST

Monitoring

Our engineering teams have identified the issue and have implemented a fix. Our teams will monitor for 1 hour before considering the issue resolved.
Posted Dec 22, 2025 - 12:06 PST

Investigating

We are currently experiencing a minor issue affecting LXP: Talent Marketplace for AP and EU Regions. Users may notice the page (like Current Job Role, job vacancies) not loading properly.

Our team is actively working on the identification of the cause.

We appreciate your patience and will provide updates as we make progress.
Posted Dec 22, 2025 - 10:20 PST
This incident affected: Australia (Web) and Europe (Web).