Minor Issue - Service Disruption in Analytics Plus for US West and EU regions

Incident Report for EdCast by Cornerstone

Resolved

We have not observed any more error on analytics plus during our monitoring. Marking it resolved.
Posted Sep 02, 2026 - 20:48 PDT

Update

We are continuing to monitor for any further issues.
Posted Sep 02, 2026 - 13:44 PDT

Monitoring

Our engineering team has resolved the issue. Analytics Plus reports and Dashboards are loging successfully now.

We will keep the status page for monitoring for next 24 hours before marking it resolved.

Thank you for your understanding and patience.
Posted Sep 01, 2026 - 20:37 PDT

Update

We are currently experiencing a disruption affecting the Analytics Plus reports on US West and EU regions

Analytics plus shows "Trouble loading data" for all reports/dashboards.

Our engineering team is actively investigating the root cause and working to restore full functionality as quickly as possible.

We understand the importance of this service and sincerely apologize for the inconvenience. Updates will be provided as we make progress toward resolution.
Posted Sep 01, 2026 - 19:54 PDT

Update

We are currently experiencing a disruption affecting the Analytics Plus reports on FRA, US West, EU Swimlanes.

Analytics plus shows "Trouble loading data" for all reports/dashboards.

Our engineering team is actively investigating the root cause and working to restore full functionality as quickly as possible.

We understand the importance of this service and sincerely apologize for the inconvenience. Updates will be provided as we make progress toward resolution.
Posted Sep 01, 2026 - 19:20 PDT

Investigating

We are currently experiencing a disruption affecting the Analytics Plus reports on FRA, US West, EU Swimlanes.

Analytics plus shows "Trouble loading data" for all reports/dashboards.

Our engineering team is actively investigating the root cause and working to restore full functionality as quickly as possible.

We understand the importance of this service and sincerely apologize for the inconvenience. Updates will be provided as we make progress toward resolution.
Posted Sep 01, 2026 - 19:19 PDT
This incident affected: US West (Data and Analytics) and Europe (Data and Analytics).