Latency in EU Production

Incident Report for EdCast by Cornerstone

Resolved

The latency issue in the EU Production environment has been resolved, and the sites are now loading as expected.
Posted Jan 29, 2026 - 20:06 PST

Investigating

We are currently experiencing performance issues in the EU Production environment, and our team is actively investigating the issue to restore normal response times and will continue to provide updates as we progress.

Thank you for your patience and understanding.
Posted Jan 29, 2026 - 19:46 PST
This incident affected: Europe (API, Web, Data and Analytics, Content Integrations).