Minor Issue - Elevated Latency Observed in US West Prod 03

Incident Report for EdCast by Cornerstone

Postmortem

Issue Summary:
Across two separate incidents on September 1 and 2, 2026, customers in the US West region experienced application performance degradation, including increased response times and intermittent Gateway Timeout (504) errors.

The incidents were associated with an unexpected and sustained increase in API traffic within the environment, which placed significant demand on shared infrastructure resources and affected overall platform performance.

Root Cause:
The incidents were caused by an unusually high and sustained volume of API requests originating from a single integration. The request volume exceeded expected usage patterns and consumed a significant amount of available infrastructure resources, resulting in resource contention and degraded application performance.

Corrective Action:
Cornerstone increased infrastructure capacity to stabilize platform performance and investigated the source and pattern of the increased API traffic. Once the source was identified, the abnormal traffic was restricted to prevent further impact. Following these actions, platform performance returned to normal, and the environment was monitored to confirm continued stability.

Preventive Measures:
To reduce the risk of a similar issue, Cornerstone has taken the following actions:

  • Implemented additional monitoring and alerting to provide earlier notification when abnormal resource consumption or API traffic patterns are detected.
  • Initiated a review of additional usage-based controls, including throttling mechanisms, to better contain unusually high resource consumption and reduce the potential for broader platform impact.
Posted Sep 09, 2026 - 13:09 PDT

Resolved

This incident has now been resolved.

Thank you for your understanding and patience.
Posted Sep 01, 2026 - 17:28 PDT

Monitoring

Engineering has identified and applied a fix. We are currently monitoring and will update this incident to Resolved after at least 1 hour if no repeat occurrences.
Posted Sep 01, 2026 - 16:07 PDT

Investigating

We are currently investigating reports of increased latency across Production for US West Prod 03. Users may experience slowness and intermittent timeouts when interacting with the portal.

Our engineering team is investigating the root cause.

We are actively working to restore normal response times and will continue to provide updates as we progress.

Thank you for your patience and understanding.
Posted Sep 01, 2026 - 14:55 PDT
This incident affected: US West (Web, API, Data and Analytics, Content Integrations).