Minor Issue - Elevated Latency Observed in EU

Incident Report for EdCast by Cornerstone

Postmortem

Issue Summary:
On March 2, increased latency was observed across services in the EU region. During the incident window, users experienced slower response times while navigating the platform and certain API requests had slower response times. Service availability remained intact, but overall performance was degraded until mitigation was applied.

Root Cause:
The incident was caused by an abnormally high number of database connections. The excessive connections increased CPU and memory consumption within a dependent service, exhausting available resources and degrading its performance. This degradation propagated latency to services across the EU region.

Corrective Action:
Resource allocation (CPU and memory) for the impacted service pods was increased to stabilize the workload and reduce latency. Following this adjustment, monitoring confirmed that system performance returned to normal levels.

Preventive Measures:
To reduce the risk of recurrence, we are taking the following action:

  • Update the application logic to limit unnecessary database connections, preventing excessive resource consumption that can lead to service degradation.
Posted Mar 13, 2026 - 15:34 PDT

Resolved

After careful monitoring, the issue has now been resolved.
Posted Mar 02, 2026 - 11:02 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2026 - 07:43 PST

Update

Update as of March 2nd, 5am PST:
The issue remains under active investigation and is being treated with the utmost priority.
Posted Mar 02, 2026 - 05:28 PST

Investigating

We are currently investigating reports of increased latency affecting EU PROD. Users may experience slower load times, delayed responses when interacting with overall application.

We are actively working to restore normal response times and will continue to provide updates as we progress.

Thank you for your patience and understanding.
Posted Mar 02, 2026 - 01:27 PST
This incident affected: Europe (API, Web, Data and Analytics, Content Integrations).