System Latency on GCP Asia region

Incident Report for EdCast by Cornerstone

Resolved

The issue is resolved and we haven't noticed any spike or latency for last 5 hours at our end in the server logs.
Posted Mar 21, 2025 - 06:38 PDT

Monitoring

We are no longer seeing latency and application should be working fine now. We continue to monitor the status.
Posted Mar 21, 2025 - 04:34 PDT

Update

We are continuing to investigate this issue with our server team.
Posted Mar 21, 2025 - 02:50 PDT

Update

We are continuing to investigate this issue.
Posted Mar 21, 2025 - 00:46 PDT

Investigating

We are seeing latency for the GCP ASIA Prod region due to which the users are not able to login or the login times are high. We are working with our server team to investigate the issue on priority.
Posted Mar 20, 2025 - 22:30 PDT
This incident affected: Mumbai (GCP) (Web, API, Data and Analytics, Content Integrations).