EU Degraded Performance - High Response Time

Incident Report for EdCast by Cornerstone

Resolved

Following successful resolution deployment and monitoring this incident is concluded Resolved.
Incident start time: 00:40 AM PST
Incident end time: 01:10 AM PST
Posted Mar 24, 2025 - 02:15 PDT

Monitoring

A fix for this issue has been implemented and we are seeing improvements starting at 01:10 AM PST.
We will continue monitoring before concluding this incident as Resolved.
Posted Mar 24, 2025 - 01:47 PDT

Investigating

Clients with portals on this Swimelane may experience platform lag impacting logins and overall platform performance.
Our engineers are working to resolve this issue with the highest priority.
Posted Mar 24, 2025 - 01:15 PDT
This incident affected: Europe (Web).