Analytics Plus Module Not Accessible

Incident Report for EdCast by Cornerstone

Resolved

Cornerstone engineers have fixed this issue. The Analytics Plus module is now available for use.
Posted Jan 05, 2026 - 00:25 PST

Update

The issue has been resolved for customers in the EU, AU, and US West regions. We are currently working to address the issue for customers in the remaining regions.

We appreciate your patience and will continue to provide updates as we make progress.
Posted Jan 04, 2026 - 23:00 PST

Investigating

The AnalyticsPlus module is not accessible, resulting in a blank screen when attempting to use it. The issue is replicable and has been escalated to the engineering team for further investigation.

We appreciate your patience and will provide updates as we make progress.
Posted Jan 04, 2026 - 21:46 PST
This incident affected: US East (Web, API, Data and Analytics, Content Integrations), Europe (API, Web, Data and Analytics, Content Integrations), Australia (Web, API, Data and Analytics, Content Integrations), US West (Web, API, Data and Analytics, Content Integrations), US Central (GCP) (Web, API, Data and Analytics, Content Integrations), Mumbai (GCP) (Web, API, Data and Analytics, Content Integrations), US East 08 (Web, API, Data and Analytics, Content Integrations), US-East-01 (Uptime, Response Time), US RES (Uptime, Response Time), Europe 10 (Uptime), US West 09 (Uptime), and NOVA.