Elevated Latency Observed on Southeast PROD

Incident Report for EdCast by Cornerstone

Postmortem

Incident Summary:
On December 3, 2025, clients hosted in the AP Southeast region experienced intermittent slowness. During this period, users faced delays when accessing their portals, with pages loading more slowly than expected. Additionally, a few dependent APIs returned errors, further contributing to the degraded user experience.

Root Cause:
The primary cause was performance degradation in a dependent service that our platform relies on for real-time data retrieval. This dependent service was experiencing delays because of an underlying Redis issue.

Corrective Action:
We restarted the Redis instance, which resolved the issue. Redis is hosted on a third-party cloud vendor, and the restart restored it to normal performance.

Preventive Measures:
To minimize recurrence, Cornerstone is taking the following actions:

  • Implement Redis Health Monitoring & Alerts: Set up enhanced health checks and real-time alerts for Redis latency, connection failures, and resource usage so issues are detected early.
  • Optimize Redis Configuration & Resource Allocation: Review and fine-tune Redis memory, eviction policies, and CPU allocation to prevent performance bottlenecks.
Posted Dec 10, 2025 - 12:58 PST

Resolved

This incident is concluded resolved.
Posted Dec 04, 2025 - 01:53 PST

Monitoring

The performance issue with the Southeast PROD has been resolved, and the sites are now loading as expected. We are currently monitoring the environments to ensure continued stability.
Posted Dec 03, 2025 - 21:32 PST

Investigating

We are currently experiencing slowness on the production site for South East. We are actively working to restore normal response times and will continue to provide updates as we progress.

Thank you for your patience and understanding.
Posted Dec 03, 2025 - 19:40 PST
This incident affected: Australia (Web, API, Data and Analytics, Content Integrations).